• Ciao Guest - You’ve landed at the ultimate Guzzi site. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER - Use the CONTACT above if you need help. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have, have likely been already answered. DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back in and reply within 24 hours, or your post will be deleted. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! Be sure to see our STORE link also above for our 700+ product inventory, including many of our 100% Made-in-SoCal-USA GTM products and engine kits. In SoCal? Click the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work, and don't miss our GT MotoCycles® (not) art on the BUILDS tab above. WE'RE HERE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED - DO NOT EMAIL AND ASK QUESTIONS OR ASK TO CALL YOU.
  • There is ZERO tolerance on personal attacks and ANY HYPERLINKS to PRODUCT(S) or other competing website(s), including personal pages, social media or other Forums. This ALSO INCLUDES ECU DIAGnostic software, questions and mapping. We work very hard to offer commerically supported products and to keep info relevant here. First offense is a note, second is a warning, third time will get you banned from the site. Sorry to have to do this, but we don't have the time to chase repeat (and ignorant) offenders. This is NOT a social media platform; It's an ad-free, privately funded website, in small help with user donations. Be sure to see our online STORE link above; GTM product purchases help support the site, or you can upgrade your Forum profile or DONATE via the link above.
  • Like the new V100, GuzziTech is full throttle into the future! We're now running on an all-new server and we've updated our Forum software. The visual differences are obvious, but hopefully you'll notice the super-fast speed. If you notice any glitches or have any issues, please post on the Site Support section at the bottom. If you haven't yet, please upgrade your account which is covered in the Site Support section or via the DONATE tab above. We really appreciate every $ and your support to keep this site ad-free. Create an account, sign in, upgrade your account, and enjoy. See you on the road in 2022.

Search results

  1. sanddweller

    Sidestand Light wont go off

    Ill certinaly get one here from Todd if its the fastest option. Im in Dubai.. Not sure what youmeant "You have to get an ecu loaded from other mfg" -so is it just the map that needs loadin if I can locally source a 5AM? Ive got the GizziDiag software and gear to do that is thats all that is...
  2. sanddweller

    Sidestand Light wont go off

    Ok got a longish history on this that may or may not be related. 1. Bike has been in Bribsane Australia while I have been in Dubai for 21 months. 2. I Visited Brisbane last in December and decided to ship th ebike to Dubai. Rode it to Brisbane dealer, had it crated. Id just clocked over...
  3. sanddweller

    Coffee break.

    Who is on the Stelvio? Get him/her over to the Stelvio Owners Group on facebook.. :) facebook.com/groups/888995181188209
  4. sanddweller

    I Still Love it !

    From what I read recently, no date is yet set for the trip... So just maybe it could be fined with a new model stelvio.. Surely if the v7 and Cali can be EU4 compliant then they could also do the 1200s.
  5. sanddweller

    I Still Love it !

    You have to wonder then, if recent news is correct about MG support for Ewan McGreggor using a Stelvio for his next big "long way" trip to Sth America. Surely they would not do this without a bike to sell. Could be we may see a new bike and promotion tied to that?
  6. sanddweller

    Horrible Fuel Mileage

    My mileage, in Miles per USGallon(blue), Imperial Gallon(red), and Litres per 100km Standard map. 2012 NTX. (over 30,000km x-axis is odometer in KM)
  7. sanddweller

    Wanted Right Handguard

    Hi Gerry - I have one from a 2012, but I'm in Brisbane/Australia. Probably cost prohibitive to post vs you getting after-market or new set complete. Let me know however if you need it. cheers --geoff
  8. sanddweller

    Wont Start...

    Well I may have fixed, or at least isolated the problem to the GIVI brake lights. You are right they are a sprung contact system, rather than a plug. I had a previous problem with those, that the vibey Stelvio caused the original sprung connections to wear so much they stopped working (people...
  9. sanddweller

    Wont Start...

    Found the GPS plug. Don't know why I didnt see it before :p - OK so the GPS cable and plug seem ok. There was one thing - the cable to the tail light had been patched, by my dealer, to splice in cable for the stop lights in my GIVI top box. I pulled the tail apart tonight to check these. The...
  10. sanddweller

    Wont Start...

    I've checked each of the mods in the doc you sent, Canuck. All seems ok - although mines a 2012, and I wonder if all apply. The "Main cable Harness protection" isnt applied, but the cable is secured with a tie, fixed to the headlight support bracket. The frame shield is applied, but the cable...
  11. sanddweller

    Another starting issue

    I had a similar problem some time ago. Left it off for a longer period, and it was ok later - similar to you. Get into diagnostics and see if there's any error logged. IIRC, Mine was something like a 'dashboard error', which I cleared and didnt think about again. :-/
  12. sanddweller

    Wont Start...

    Relay confusion aside, the original problem was a blown #1 Aux fuse. I replaced the fuse, and its blown twice since. I've not found anything untoward - everything seems to be working as expected. Heated grips are off, but work ok. lo/hi Lights, brake lights, horn all ok. I don't have GPS wired...
  13. sanddweller

    Solution tyre noise Dunlop RoadSmart III 2009 Stelvio

    Nice. I've only managed 6,000 miles from (2 of) the PR4 rear (and thats the standard, not trail version). 9,000miles from the trail front.
  14. sanddweller

    Ouch!? Unknown noise

    Yep. Based on the other post figured something like that. It's been over a year and the clutch has only started slipping so it didn't "stop" me, although I'd have generally expected more than 50000km from a clutch plate.
  15. sanddweller

    Ouch!? Unknown noise

    Its been over a year since the issue reported here, and the bike has been ok, but now clutch is starting to slip a bit, and I'll be looking at a replacement soon. (I posted earlier if there was a tutorial on this, but no responses :-/) Not sure if to tackle this myself to save labour costs...
  16. sanddweller

    Wont Start...

    Hi Canuck.. DOH!.. That fixed it. :embarrassed: :banghead: I know I read a post somewhere (wildguzzi, maybe) that said the 5 pins could be used in place of the fours. Ill search again for that. Trap for young players. Dont believe everything you read.. Without awareness of the diode, seemed...
  17. sanddweller

    Wont Start...

    Thanks Lannis. Im pretty sure the battery is OK. its only a few months old. I dont have a dedicated battery tester, but I have a good charger that tests the battery to some extent (although not a 50amp load).
  18. sanddweller

    Wont Start...

    Thanks Canuck. Ill check that in the morning (now past 1am). You may be right.. I put new bosch 5 pin relays in. I had read they were all the same. They do have the same pin-outs, and the maintenance relay pin socket just has a blank for the center 5th pin, so accepts the 5 pin relay although...
  19. sanddweller

    Wont Start...

    Yep, one of the first things I tried was swapping the Starter Relay and the Fog light relay (these are the same type 4 pin relay), but this made no difference. I'll try disconnecting the battery entirely for a bit, and cross fingers. :-/ Am I right to question why power would be going to the...
  20. sanddweller

    Wont Start...

    Indeed. I should have checked the fuse before attempting to ride home w/o headlights instead of 'assuming' it was the relay I previously had to replace. The Aux fuse "A" that was blown, according to the service manual TEXT should be 15Amp (mine was 10Amp - and I've never changed that before, in...
Top