Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! There is zero tolerance on personal attacks and off-site links to other Forums or competing products. Also be sure to click on the STORE link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. And if you haven't seen our MotoCycle (not) art, click on the BUILDS tab above to see our work at our sister business; GT MotoCycles® -- WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.

2010 V7 cuts out under throttle

Discussion in 'V7/V85/V9 Chat & Tech' started by maidenfan84, Nov 25, 2020.

  1. maidenfan84

    maidenfan84 Just got it firing!

    Joined:
    Nov 25, 2020
    Messages:
    1
    Likes Received:
    1
    Location:
    San Jose
    Hello, loving my Moto Guzzi V7c and, unfortunately, I've ran into a hiccup. The bike starts and idles just fine, but as soon as I apply any throttle, it immediately dies out. If I really feather the clutch and give it increased throttle, it will take off but continually stutter and buck. Any ideas where to start looking? It's my primary transportation so trying to get this sorted out. Thank you, in advance!
     
    HarrierGod likes this.
  2. V700Steve

    V700Steve High Miler GT di Razza Pura

    Joined:
    Dec 8, 2008
    Messages:
    941
    Likes Received:
    345
    Location:
    Atlanta area, GA
    Sounds like a fuel filter problem. Pull pump plate and have a look. Notorious half plastic filter or loose line clamp.
     
    DeadEye, Moto-Uno and maidenfan84 like this.
  3. dale decrescenzo

    dale decrescenzo Tuned and Synch'ed

    Joined:
    Sep 4, 2020
    Messages:
    49
    Likes Received:
    32
    Location:
    Mo
    does the track control light flash when this happens ?
     
  4. HarrierGod

    HarrierGod Tuned and Synch'ed GT Contributor

    Joined:
    Aug 1, 2017
    Messages:
    39
    Likes Received:
    17
    Location:
    Colorado
    I would inspect the spark plug leads. Common problem on the V7c and V7ii.
    Pull them off the plugs and look for burn marks on the porcelain.

    I would start here because it only takes 10 seconds to check. Then move on to checking deeper.
     
    Last edited: Dec 16, 2020

Share This Page