Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER - Use the CONTACT above if we can be of help. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! Also be sure to click on the STORE link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. And if you haven't seen our MotoCycle (not) art, click on the BUILDS tab above to see our work at our sister business; GT MotoCycles® -- WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.
  2. There is ZERO tolerance on personal attacks and ANY HYPERLINKS to a PRODUCT or other competing website(s), this includes personal pages, social media or other Forums. We work very hard to keep info relevant here. First offense is a note, second is a warning, third time will get you banned from the site. Sorry to have to do this, but we don't have the time to chase repeat (and ignorant) offenders. This is NOT a social media platform; It's an ad-free, privately funded website, in small help with user donations. Be sure to see our online STORE link above; GTM product purchases help support the site, or you can upgrade your Forum profile or DONATE via the link above.

2016 V7II - Surging after fuel filter change - found issue

Discussion in 'V7/V85/V9 Chat & Tech' started by hatchb4ck, Jul 13, 2019.

  1. hatchb4ck

    hatchb4ck Just got it firing!

    Joined:
    Aug 25, 2017
    Messages:
    22
    Likes Received:
    23
    Location:
    Overland Park, KS
    I'm trying to keep my head up with regards to my 2016 V7II Stornello, but I'm struggling with it. Aside from the rough running and stalling when it rains, I have now introduced a new issue with my fuel filter change. I really wanted to order one from GT, but since I didn't have anything else to order, the shipping was about half the cost (no criticism here...just an deciding factor. I dig what GT offers us Guzzi owners) ...so using the parts cross reference, I picked up a Napa 3032 filter and some 11.3 Oetiker clamps.

    Pulled the pump, uninstalled the stock filter, installed the new filter double and triple checking the flow direction, clamped it and reinstalled. Fired up the bike and it idles, rolled the throttle on and it revs for a second or two then the rpms decrease and it backfires. If I hold the throttle steady, it will rev up and down in a regular timing pattern.

    I pulled the tank back off, pulled the new filter, reset the hoses, installed new clamps, pump back in the tank, and back on the bike... Naively hoping that maybe I didn't have the clamps on correctly the first time. Nope, still having the issue.

    The behavior, to me, is a fuel pressure/volume issue. Thoughts?
     
    Poppe likes this.
  2. hatchb4ck

    hatchb4ck Just got it firing!

    Joined:
    Aug 25, 2017
    Messages:
    22
    Likes Received:
    23
    Location:
    Overland Park, KS
    Found the issue....the tank wasn't venting properly. I discovered it while leaning over the tank while lifting it from the rear. I heard an audible "venting" sound. So I popped the gas cap, checked all the vent lines and made sure everything is sorted. Started it up...no surging issue.

    Hopefully this post helps remind others to check the tank vents after reinstalling the tank.
     
  3. sib

    sib Cruisin' Guzzisti

    Joined:
    May 12, 2013
    Messages:
    322
    Likes Received:
    77
    Location:
    Providence, RI
    My $0.02: It's easy to pinch the vent hose closed when putting the tank back on. When you lifted the rear of the tank, the hose became unpniched. I suspect that many (maybe all) reports of tanks not venting properly are due to pinched vent hoses rather than anything being wrong with the venting valve.
     
    Poppe likes this.
  4. Poppe

    Poppe Cruisin' Guzzisti GT Contributor

    Joined:
    Apr 28, 2016
    Messages:
    314
    Likes Received:
    132
    Location:
    Los Angeles
    What is going on with your surging? Like what does that mean?

    I ask cause I"m trying to track down a demon right now and kind of just lost for words on what else I could possibly do to fix the issue. For about the last 1.5 years I've had "surging" and a gargling exhaust sound at specific times of the RPM range. I'll have a surge of power after a slight loss of power at 4500 rpm. I'll have a gargling exhaust if I come off the throttle then usually some slight back fires, then around 50% of the time, I'll have no power to take off - like can't get to 45mph unless i jump to 3rd gear and pull the throttle fairly close to wide - and then the power will be fine after that.

    Replaced fuel filter, cleaned up oil in breather box, replaced spark plugs twice, replaced spark plug wire, replaced battery, replaced a head gasket thing that had created residual oil up by the spark plug.

    Just kind of lost now what to do next, but wondering if I am having something similar to you. Don't hear any venting though, so maybe it's a different kind of surge?
     
  5. kiwi dave

    kiwi dave GT Reference

    Joined:
    Oct 28, 2008
    Messages:
    2,157
    Likes Received:
    402
    Location:
    Auckland, New Zealand
    Do you notice any "tank suck" when you open the gas cap on the tank?
     
  6. Poppe

    Poppe Cruisin' Guzzisti GT Contributor

    Joined:
    Apr 28, 2016
    Messages:
    314
    Likes Received:
    132
    Location:
    Los Angeles
    No tank suck on mine.
     
  7. kiwi dave

    kiwi dave GT Reference

    Joined:
    Oct 28, 2008
    Messages:
    2,157
    Likes Received:
    402
    Location:
    Auckland, New Zealand
    Is it still under warranty?
     
  8. Poppe

    Poppe Cruisin' Guzzisti GT Contributor

    Joined:
    Apr 28, 2016
    Messages:
    314
    Likes Received:
    132
    Location:
    Los Angeles
    Oh no long gone from that unfortunately.
     
  9. My name is Jeff

    My name is Jeff Cruisin' Guzzisti

    Joined:
    Jun 26, 2015
    Messages:
    146
    Likes Received:
    64
    Location:
    Australia
    Sounds like it’s running lean Are you still running the stock map?
     
  10. Poppe

    Poppe Cruisin' Guzzisti GT Contributor

    Joined:
    Apr 28, 2016
    Messages:
    314
    Likes Received:
    132
    Location:
    Los Angeles
    I don’t think this is it, I am running a custom map built for this bike and exhaust. And it’s not consistently surging and not consistently losing power. If it randomly reseted back to the stock map would that actually be a sign, and why would it go back to normal sometimes?
     
  11. GTM®

    GTM® Administrator Staff Member GT di Razza Pura

    Joined:
    Jul 1, 2009
    Messages:
    12,260
    Likes Received:
    4,464
    Location:
    Malibu
    Tyler, instead of fishing the net, just write me direct email. Too much misinformation posted... and I know your bike well outside of anything done when it’s not at my shop. ;)
    The map cannot revert. Impossible.
    It may be related to heat, sitting in the sun, or just traffic and riding conditions. These are air-cooled engines that can get cranky on warm weather. You may know enough to realize when this happens on other (farm) vehicles?
    Your bike tested A-OK last we had it. No errors, no running issues.
     
    Poppe likes this.
  12. RedHawk47

    RedHawk47 Tuned and Synch'ed GT Famiglia

    Joined:
    Jul 22, 2014
    Messages:
    94
    Likes Received:
    22
    Location:
    Berthoud, CO
    I had a somewhat similar problem. Something to check: Are the connectors fully seated and clipped in properly? I had one that wasn't, and the vibration at different rpms would cause loss of power.
     
    Poppe likes this.
  13. RedHawk47

    RedHawk47 Tuned and Synch'ed GT Famiglia

    Joined:
    Jul 22, 2014
    Messages:
    94
    Likes Received:
    22
    Location:
    Berthoud, CO
    I realized that I left out some detail: I was referring to the electrical connection to the fuel injector.
    Dan
     
    Poppe likes this.
  14. Poppe

    Poppe Cruisin' Guzzisti GT Contributor

    Joined:
    Apr 28, 2016
    Messages:
    314
    Likes Received:
    132
    Location:
    Los Angeles
    Worth a check! I've been really trying to ride the bike non stop with just Chevron high end fuel too. I fear ethanol might have crystallized on the injectors from the bike sitting when I had a leak and couldn't fix at the moment. Since I started putting 70 miles on it per day that seems to really have cleared things up and made the issue very much more in frequent.
     

Share This Page