Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! There is zero tolerance on personal attacks and off-site links to other Forums or competing products. Also be sure to click on the STORE link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. And if you haven't seen our MotoCycle (not) art, click on the BUILDS tab above to see our work at our sister business; GT MotoCycles® -- WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.

93 quota not charging

Discussion in 'Quota & TT' started by mkiv16, May 27, 2012.

  1. mkiv16

    mkiv16 Just got it firing!

    Joined:
    Jun 13, 2011
    Messages:
    6
    Likes Received:
    0
    hi, working with a friend on his 93 quota the charging is not working is there a test i can do with my multi meter on the alternater/regulator bike is starting and running fine,aslo rev counter is also out? thanks
     
  2. john zibell

    john zibell Moderator Staff Member GT di Razza Pura

    Joined:
    Oct 28, 2008
    Messages:
    8,122
    Likes Received:
    913
    Location:
    Huntsville, AL
    There are two yellow wires emanating from the stator that go to the regulator/rectifier. Disconnect these two wires from the regulator/rectifier. You should be able to read about 15 Vac or higher at idle, 40 or more Vac at 3,000, and 80 VAC or higher at 6,000 rpm. If you get these readings, the stator is OK and replace the regulator/rectifier. If you don't get those voltages, the stator is faulty. My bet is on the regulator/rectifier being faulty.
     
  3. mkiv16

    mkiv16 Just got it firing!

    Joined:
    Jun 13, 2011
    Messages:
    6
    Likes Received:
    0
    tested stator just now, it is bang on to what you said thanks alot, will order reg/rec.
     
  4. guzzirider

    guzzirider Cruisin' Guzzisti

    Joined:
    Nov 2, 2008
    Messages:
    160
    Likes Received:
    3
    If your reg / rectifier has failed it may have fried the battery too- worth checking.
     
  5. mkiv16

    mkiv16 Just got it firing!

    Joined:
    Jun 13, 2011
    Messages:
    6
    Likes Received:
    0
    will do, cheers
     
  6. Brian UK

    Brian UK GT Reference

    Joined:
    Nov 6, 2008
    Messages:
    2,058
    Likes Received:
    217
    Location:
    Addlestone, Surrey, UK
    Before launching into the expense of a new regulator, just check the earth which is via the frame fixing, this is the negative return to the battery. Well worth running a wire from the case to the battery negative.
    The red wire is connected to the battery positive?
     
  7. mkiv16

    mkiv16 Just got it firing!

    Joined:
    Jun 13, 2011
    Messages:
    6
    Likes Received:
    0
    cleaned up all earths, new battery , fitted new reg/rec ,dash light working now, and good solid 14 volts ,happy days
     

Share This Page