Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! There is zero tolerance on personal attacks and off-site links to other Forums or competing products. Also be sure to click on the STORE link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. And if you haven't seen our MotoCycle (not) art, click on the BUILDS tab above to see our work at our sister business; GT MotoCycles® -- WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.

Anyone know what this is?

Discussion in 'CARC' started by Erik Schmidt, Nov 4, 2020.

  1. Erik Schmidt

    Erik Schmidt Just got it firing!

    Joined:
    May 3, 2015
    Messages:
    4
    Likes Received:
    1
    Location:
    Canada
    2008 Norge Under the throttle bodies, above the starter motor. Totally blank, no part number or manufacturer, green thingy looks like an LED. Battery is out I am thinking grip heater ecu? Or a tiny monolith left by aliens in the distant past. Clipboard01.jpg
     
    Last edited: Nov 4, 2020
    Mayakovski likes this.
  2. DeadEye

    DeadEye Cruisin' Guzzisti

    Joined:
    Jun 13, 2020
    Messages:
    458
    Likes Received:
    219
    Location:
    Eastern Ontario - Western Quebec
    A locator / homing device planted badly by Big Brother ?
    What’s it plugged/connected to ?
     
  3. GTM®

    GTM® Administrator Staff Member GT di Razza Pura

    Joined:
    Jul 1, 2009
    Messages:
    11,498
    Likes Received:
    3,587
    Location:
    Malibu
  4. Erik Schmidt

    Erik Schmidt Just got it firing!

    Joined:
    May 3, 2015
    Messages:
    4
    Likes Received:
    1
    Location:
    Canada
    Yep that's it a GT2 O2 optimizer, LED flashes with ignition. Wonder what other surprises PO has left for me. RIght now I am having starting problems again, this time its the battery or the solenoid, was checking the solenoid electrical connections when I found the gadget.
    Thanks Todd
     
  5. Brian UK

    Brian UK GT Reference

    Joined:
    Nov 6, 2008
    Messages:
    2,039
    Likes Received:
    199
    Location:
    Addlestone, Surrey, UK
    I bet it's the wiring to the start relay.
     
  6. DeadEye

    DeadEye Cruisin' Guzzisti

    Joined:
    Jun 13, 2020
    Messages:
    458
    Likes Received:
    219
    Location:
    Eastern Ontario - Western Quebec
    BRRRRRTTTTTT !

    ( what the wrong answer buzzer ”Looks like” typed out) :wait:
     
    john zibell likes this.

Share This Page