Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER - Use the CONTACT above if we can be of help. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! Also be sure to click on the STORE link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. And if you haven't seen our MotoCycle (not) art, click on the BUILDS tab above to see our work at our sister business; GT MotoCycles® -- WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.
  2. There is ZERO tolerance on personal attacks and ANY HYPERLINKS to a PRODUCT or other competing website(s), this includes personal pages, social media or other Forums. We work very hard to keep info relevant here. First offense is a note, second is a warning, third time will get you banned from the site. Sorry to have to do this, but we don't have the time to chase repeat (and ignorant) offenders. This is NOT a social media platform; It's an ad-free, privately funded website, in small help with user donations. Be sure to see our online STORE link above; GTM product purchases help support the site, or you can upgrade your Forum profile or DONATE via the link above.

Breva wont start

Discussion in 'Chat & Tech Info' started by scate, Jun 27, 2021.

  1. scate

    scate Just got it firing!

    Joined:
    Jun 27, 2021
    Messages:
    3
    Likes Received:
    0
    Location:
    usa
    Need a little help.

    Bike in question is a 2008 Breva 1200 sport


    The owner of this bike is an acquaintance of mine and the bike was a running bike prior to repairs done. The bike ran great but 3 miles down the road at this point it died and hasnt started again. The bike will crank but does not start. My first instinct was to go over what was last touched but not finding anything that could have caused the issue.

    Error codes P0351 Left coil short circuit to battery positive, P0352 Right coil short circuit to battery positive

    Repairs done:

    First thing that was done was replacing a clutch lever after she dropped it in the driveway (pretty straight forward repair).

    Second was to replace her oil pressure sensor. She was getting a random error light that came and went but wasn’t throwing a code. After some research she thought it was worth replacing to see if the sensor was the culprit.

    To replace the sensor, I had to change out the connector to match the new style sensor. I also removed the revolution sensor to make access to the pressure sensor easier.

    Everything seems good here. The revolution senor is recognized and throws a code if disconnected and diagnostic software sees rpms as the engine is cranking.

    Battery was also replaced. Battery was weak and could only start the bike once or twice without recharging. Bike was started multiple times with no issues with new battery.


    Diagnosing Codes:

    Ive tested both positive sides on the plugs going to each coil. I took a light tester to the positive wire of the coil plug and went to battery ground. At start up the light filps on then off when you hear the relay click, and lights up when cranking the motor.

    However on the negative side. Taking the light tester from positive battery to negative wire of coil plug I get no light. The ecu doesn’t seem to be giving me the ground I need.

    At this point Im thinking a bad ecu or ground wire from ecu.

    I haven’t gotten a chance to look to deeply at the ecu. It appears the ecu ground is blue green wire and is bolted to the under side of the ecu? From this bolt to battery ground I have continuity.

    Just wanting to get others point of view on this. Thanks for the help.
     
  2. scottmastrocinque

    scottmastrocinque Scott Mastrocinque GT di Razza Pura

    Joined:
    Jun 26, 2011
    Messages:
    1,666
    Likes Received:
    1,372
    Location:
    Findlay, Ohio
    Hi. Not sure what you are trying to do with all of that. It's not making sense to me. I doubt your ECU is bad. More likely, the coil.

    Go to a local auto parts store and get yourself a spark gap jump tool like this. (I actually have 4 of them just in case I am working on a 4 cylinder and want to observe all spark firing.)

    lil-20700_xl.jpg

    Place it in between the ignition wire and the plug, clip the cord to a good known ground point on the engine, and crank the engine.

    Observe the brightness and sound of the spark, if any.

    If there is no spark jumping the gap, then you indeed have a bad coil which can be verified by reading the primary and secondary resistance across the coil.

    Post your results back here.
     
  3. scate

    scate Just got it firing!

    Joined:
    Jun 27, 2021
    Messages:
    3
    Likes Received:
    0
    Location:
    usa
    I picked one up. I do have spark. So proceeded toward fuel. I shot a little starter fluid down the intake and the bike started right up.
     
  4. tobinh

    tobinh Cruisin' Guzzisti GT Famiglia

    Joined:
    Oct 15, 2016
    Messages:
    181
    Likes Received:
    98
    Location:
    Burnaby, BC
    pull the fuel line, push start button. if fuel shoots out, at least the pump/filter assembly is working.

    I suspect it won't, and you'll be replacing the fuel filter.
     
  5. scate

    scate Just got it firing!

    Joined:
    Jun 27, 2021
    Messages:
    3
    Likes Received:
    0
    Location:
    usa
    I can here the whirl of the pump when I turn the key on. I disconnected the fuel hose, when flipping on the key no fuel pumps out.
     
  6. tobinh

    tobinh Cruisin' Guzzisti GT Famiglia

    Joined:
    Oct 15, 2016
    Messages:
    181
    Likes Received:
    98
    Location:
    Burnaby, BC
    ah ha! I guess you know what you're doing next.

    edit: wait, did you push the start button?
     

Share This Page