• Ciao Guest - You’ve landed at the ultimate Guzzi site. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER - Use the CONTACT above if you need help. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have, have likely been already answered. DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back in and reply within 24 hours, or your post will be deleted. Note there's decades of heavily experienced Guzzi professionals on this site, all whom happily give endless amounts of their VALUABLE time for free; BE COURTEOUS AND RESPECTFUL! Be sure to see our STORE link also above for our 700+ product inventory, including OEM parts and many of our 100% Made-in-SoCal-USA GTM products and engine kits. In SoCal? Click the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work, and don't miss our GT MotoCycles® (not) art on the BUILDS tab above. WE'RE HERE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED - DO NOT EMAIL AND ASK QUESTIONS OR ASK TO CALL YOU.
  • There is ZERO tolerance on personal attacks and ANY HYPERLINKS to PRODUCT(S) or other competing website(s), including personal pages, social media or other Forums. This ALSO INCLUDES ECU DIAGnostic software, questions and mapping. We work very hard to offer commerically supported products and to keep info relevant here. First offense is a note, second is a warning, third time will get you banned from the site. We don't have the time to chase repeat (and ignorant) offenders. This is NOT a social media platform; It's an ad-free, privately funded website, in small help with user donations. Be sure to see our online STORE link above; ALL product purchases help support the site, or you can upgrade your Forum profile or DONATE via the link above.
  • Like the new V100, GuzziTech is full throttle into the future! We're now running on an all-new server and we've updated our Forum software. The visual differences are obvious, but hopefully you'll notice the super-fast speed. If you notice any glitches or have any issues, please post on the Site Support section at the bottom. If you haven't yet, please upgrade your account which is covered in the Site Support section or via the DONATE tab above, which gives you full site access including the DOWNLOADS section. We really appreciate every $ and your support to keep this site ad-free. Create an account, sign in, upgrade your account, and enjoy. See you on the road in 2022.

DISCONTINUED ALARIS/Centurion/VDSTS Info - Instructions

canuck1969

GT Reference
GT Contributor
Joined
May 31, 2012
Messages
1,243
Location
Burlington, Ontario
Hey folks...just a heads up if you have downloaded the latest version of Centurion S. When you first install and run it, several of the options are not present on the drop down lists (ie. TPS reset). Once you install the cables and hook it up to a battery, it will recognize the cable for the specific ECU and then the options will be unlocked. For my Stelvio this was the case.

The old version had all the options but those not available were grayed out. For the new version, it only displays the options that are available for your ECU.
 

mgmike

Cruisin' Guzzisti
GT Contributor
Joined
May 23, 2014
Messages
183
Location
Tallahassee, FL
Greetings,

I have the Centurion system install hooked it up today..Looks really cool.
Now I need to figure out how to use it..LOL My question is how do I adjust the
TPS after I purchase the full fueling kit? It looks like all I do is open and close the throttle in
the TPS portion of the program. Diags
Am I correct?

Thank
Mike
 

ds99

Tuned and Synch'ed
GT Contributor
Joined
Dec 5, 2014
Messages
30
Location
uk
you click on the 'active settings' button (screwdriver symbol), and choose TPS, answer yes to the confirmation question, it then counts down from 10 and (hopefully) says "PASS".
 

guzzitnlover

Just got it firing!
GT Famiglia
Joined
Oct 8, 2016
Messages
14
Location
USA
Do you have to log in via your email w/ internet access before you can use Alaris?

Thanks
 

guzzitnlover

Just got it firing!
GT Famiglia
Joined
Oct 8, 2016
Messages
14
Location
USA
Do you have to log in via your email w/ internet access before you can use Alaris?

Thanks

I purchased my Alaris direct from TechnoResearch as on the site here it showed only one bike modules. TR stated the following to me:

Our Alaris-MM will do the job. It includes all the Marelli ECU up to the 7BM (including P8).


figured out one issue. Reason it was updating all the time and needing me to put in my e-mail address for account info was:

I was clicking on the icon on my deck top labeled " TechnoReasearch Launcher". Instead I opened "TR" from my programs and no problem bringing up the program with no internet access and not needing to enter my account info but...

I can connect and check everything I want on the Breva which has the MM-IAW5AM ECU.

I then hook everything up to the 98 EV using the P8, change the ECU by clicking on the motorcycle icon to the P8. I then turn ignition on and click TALK. See connecting at the bottom left of the program and to the right see where it states P8 and then see the two red markers go away and ECU is connected. Still same problem, no readings on the meter program or anything else...not even battery status?

Noted on the cardboard slip card as well as the Alaris module it states "MM-IAW5AM". I wonder if this is the correct Alaris module?

Or do I have another issue?

Thanks 20180922 203139
 

guzzitnlover

Just got it firing!
GT Famiglia
Joined
Oct 8, 2016
Messages
14
Location
USA
For this question I think it is best to contact Techno Research direct.

Yes, I have been going back and forth with this issue. Had some replies last night and even one early this morning. Was told that they will check into it Monday morning.

I was told when I purchased the Alaris from TechnoResearch that the module box would look the same but the components were different. However I'm suspect to the fact that the cardboard sleeve and back of the module plainly state MM-IAW5AM.

I was wondering if anyone else here has a multi-functioning Alaris that will work on all the Marelli ECU's?

Thanks
 

ausguzzi

Just got it firing!
Joined
Mar 21, 2011
Messages
16
Location
Queensland, Australia
I tried to do a TPS reset on my 2012 V7 yesterday. The Centurion Pro stops at the ....connecting... stage (with a window suggesting 1. connect battery, 2 . turn on kill switch etc). It was connected to a good 12V battery, unlocking key was inserted, diagnostic cable to a 2nd USB port, 15RC ECU selected.
It has worked previously. Any thoughts on what may be happening? - the laptop has Windows 10 if that is a thought..thanks in anticipation.
 

GTM®

Administrator
Staff member
GT di Razza Pura
Joined
Jul 1, 2009
Messages
12,957
Location
Malibu
I tried to do a TPS reset on my 2012 V7 yesterday. The Centurion Pro stops at the ....connecting... stage (with a window suggesting 1. connect battery, 2 . turn on kill switch etc). It was connected to a good 12V battery, unlocking key was inserted, diagnostic cable to a 2nd USB port, 15RC ECU selected.
It has worked previously. Any thoughts on what may be happening? - the laptop has Windows 10 if that is a thought..thanks in anticipation.
Contact TR direct; http://technoresearch.com/index.php/contact/contact-us -- with your info and phone number (and include your time zone), and they will call or email you for help.
 

ausguzzi

Just got it firing!
Joined
Mar 21, 2011
Messages
16
Location
Queensland, Australia
Thanks for the rapid reply, Todd. I have contacted TR.
The V7 has had your reflash and has run beautifully except for an intermittent cough when cold . But now it misses at low RPM's especially when cold and has low power. Sparkplugs indicate quite a rich mixture especially RHS. I have replaced the (Iridium) plugs but no improvement. Any thoughts?. I run our 98 octane fuel. airfilter is BMC (cleaned recently) and it has quite open pipes with a smaller diameter crossover pipe. Could it be the O2 sensor perhaps?
I still have the 2012 Stelvio as well. It is going well.

thanks Howard

Contact TR direct; http://technoresearch.com/index.php/contact/contact-us -- with your info and phone number (and include your time zone), and they will call or email you for help.
 

GTM®

Administrator
Staff member
GT di Razza Pura
Joined
Jul 1, 2009
Messages
12,957
Location
Malibu
Thanks for the rapid reply, Todd. I have contacted TR.
The V7 has had your reflash and has run beautifully except for an intermittent cough when cold . But now it misses at low RPM's especially when cold and has low power. Sparkplugs indicate quite a rich mixture especially RHS. I have replaced the (Iridium) plugs but no improvement. Any thoughts?. I run our 98 octane fuel. airfilter is BMC (cleaned recently) and it has quite open pipes with a smaller diameter crossover pipe. Could it be the O2 sensor perhaps?
I still have the 2012 Stelvio as well. It is going well.

thanks Howard
Welcome, and please email me. I can’t reply to or monitor the Forum in this way.
 

Hydrolastic

Tuned and Synch'ed
GT Contributor
Joined
May 25, 2020
Messages
94
Location
Pacific NW
It looks like some things have changed at Techno Research. I can do a Google search for Alaris, but I then just get redirected to the new home page of https://technoresearch.info/ . The Centurion software is only listed for H-D, Victory, and Indian. Does anyone know if this is still the same product, or have they gone in a different direction?

Dave
 

GTM®

Administrator
Staff member
GT di Razza Pura
Joined
Jul 1, 2009
Messages
12,957
Location
Malibu
It looks like some things have changed at Techno Research. I can do a Google search for Alaris, but I then just get redirected to the new home page of https://technoresearch.info/ . The Centurion software is only listed for H-D, Victory, and Indian. Does anyone know if this is still the same product, or have they gone in a different direction?
New direction, as their Alaris business didn't support them, so off to HD land where people spend ridiculous amounts of money.
 
Top