Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! There is zero tolerance on personal attacks and off-site links to other Forums or competing products. Also be sure to click on the STORE link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. And if you haven't seen our MotoCycle (not) art, click on the BUILDS tab above to see our work at our sister business; GT MotoCycles®-- WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.

Early Norge oil pump FAILURE

Discussion in 'BNS12 Reference Topics/Recalls' started by GT-Rx®, Feb 14, 2011.

  1. Petrov

    Petrov Tuned and Synch'ed GT Contributor

    Joined:
    Jun 30, 2010
    Messages:
    52
    Likes Received:
    0
    Looking at all the failed pumps the all look cracked/broken apart. Did Luigi decide to make a pizza in the heat treating oven instead of turning it up and heat treating oil pumps? :)
     
  2. P.odono76a

    P.odono76a Just got it firing!

    Joined:
    Mar 28, 2011
    Messages:
    9
    Likes Received:
    0
    I've got update for low pressure warning lights.Removed necessary bits and found puddle of oil around oil pressure sensor.Removed connector and oil was inside connector.Looks like oil was travelling up pin paths.Sensor is bad.While in area I will put test gauge in sensor port and check pump pressure.Also noted 3 more disturbing items.Found 2 ea washers laying in the sensor oil puddle.Oil inside L/H throttle body.Poorly routed breather line on left side that chaffed the outer protective cover of the inner throttle body control cable.Also suspect that the vaccumn line that goes to Air box bottom from the throttle bodies was not connected.More oil in the air box than I'd like to see.Not pointing any fingers, but that was my first trip between those cylinders.Hoping several issues are corrected with upcoming TLC.I will post if anything that is negative reality comes out of pump pressure check.Keeping things to the bright side,We're on the way up!Pete
     
  3. Android

    Android Cruisin' Guzzisti GT Famiglia

    Joined:
    Mar 7, 2014
    Messages:
    152
    Likes Received:
    12
    Location:
    Frogham Hampshire. UK

    From my engineering perspective I think the outer rotor cracks because of too much clearance between it and its aluminium housing so that when the cold oil is compressed it causes the rotor to "bulge" at the thinnest point until it eventually cracks/fractures (too many bulge cycles)
     
  4. Petrov

    Petrov Tuned and Synch'ed GT Contributor

    Joined:
    Jun 30, 2010
    Messages:
    52
    Likes Received:
    0
    I guess Luigi was eating Pizza instead of checking final dimensions then :)
     
  5. Brian UK

    Brian UK GT Reference

    Joined:
    Nov 6, 2008
    Messages:
    2,033
    Likes Received:
    197
    Location:
    Addlestone, Surrey, UK
    On mine, the inner rotor was quite loose on the shaft, allowing quite a lot ofplay. The new pump was solid on the shaft. I think the original one broke up because of this play.
    I have also seen a pump (fitted to a 1200s, on which the flats on the inner rotor which engage the shaft had worn away completely, allowing the inner rotor to freewheel on the shaft. Owner is still trying to source a replacement crank as the original is nitrided and cannot be reground.
     
  6. Stormtruck2

    Stormtruck2 Tuned and Synch'ed

    Joined:
    Aug 31, 2010
    Messages:
    25
    Likes Received:
    0
    Location:
    Mechanicsville IOwa
    I have ordered a new sensor, hoping that that is the problem rather than the pump. I have gotten the triangle of death for a second upon start up, but never an oil can. Lots of oil in that area also, so hopefully the new sensor cures it.
     
    Last edited: Aug 24, 2014
  7. guzzibob

    guzzibob GT Reference

    Joined:
    Oct 29, 2008
    Messages:
    1,189
    Likes Received:
    4
    Location:
    Los Angeles, CA
    Yes, that sounds like failure is in process, and your vin number is very close to the known grouping of the vast majority of failures, almost all VIN ending 112208-112305.
     

Share This Page