RentAGuzzi Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the Service tab above for the best in service, tires, tuning and installation of our products or custom work. NEW REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - AND PLEASE DON'T BE A DRIVE-BY POSTER: Most questions you may have are well answered on the Forum. As a common courtesy, check back if you are posting elsewhere on the web. There is zero tolerance on personal attacks and off-site links to other Forums or competing products. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free - be courteous. Also be sure to click on the Store link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We are still mostly a one man operation (not Amazon), so thanks in advance for your patience on orders. PLEASE refrain from emailing about your order Status, as you will get an email with tracking info when your order goes out; Email inquiries on orders slows everything down. We cannot answer questions direct unless it’s about something on the Store or that you have purchased from us. We do NOT have a phone number - We are online only - Do not email and tell us to call you. You will find us highly responsive via email on the Contact page with any questions on our products (only). We appreciate the consideration, understanding and your business... past and future. Also be sure to see our GTMotoCycles.com custom BUILDS tab above.
  2. Ciao Guest, ALERT FOR Store purchases - riding season is here, so we know everyone wants it yesterday. However, lead times are long and many things are sold out or back-ordered, and there isn't much we can do to rush anything. Always best to buy off Season when things are in stock. Also, there are many seasonal holidays this time of year, both here and in Europe (particularly the Italian August Holiday month), so please be patient! We aren't Amazon. We do our best to get things out as quickly as possible, and we also aren't in control of things like customs & weather delays, etc. Please note GuzziTech and the GTM Store is largely a ONE man operation. Requests for phone calls will be deleted. We are online only. Orders are currently being shipped once or twice a week. You can always sign into the online Store system to check the status. Please refrain if at all possible about emailing for an update; If you must ask for order info, please reply on the actual order email. You will get shipping info when it goes out via our online Store system (check your Spam folder), and if you want to cancel your order, please notify us direct email (do not post or use the Forum) and allow 7-10 business days for a reply BEFORE OR JUST disputing the charge. We don't want your money if we can't deliver. Special order items are subject to a 15-20% cancellation fee. Thanks for your understanding and support.

Getting the "SERVICE URGENT" error code

Discussion in 'Cal 1400 8V' started by Glenn Thorpe, Apr 30, 2018.

  1. Glenn Thorpe

    Glenn Thorpe Tuned and Synch'ed

    Joined:
    Nov 25, 2015
    Messages:
    53
    Likes Received:
    14
    Location:
    Tempe, AZ
    Today I got the "SERVICE URGENT" with flashing general warning light error code. And the "ride home mode" has kicked in. Turned the ignition off and restarted a few times but it would not go away. Unfortunately I have no way to read the error code myself.

    The bike is a 2016 1400 Eldorado with about 1600 miles. I have had zero problems with the bike. I bought it from the original owner in December and he said the warranty was good until Aug'2018.

    Can someone recommend a good shop in the Phoenix area that does warranty work on Guzzi's? Also how can I verify the warranty has not expired?

    Thanks,
    Glenn
     
  2. kiwi dave

    kiwi dave GT Reference

    Joined:
    Oct 28, 2008
    Messages:
    1,799
    Likes Received:
    245
    Location:
    Auckland, New Zealand
    Is your "SERVICE URGENT" code still showing?
     
  3. Glenn Thorpe

    Glenn Thorpe Tuned and Synch'ed

    Joined:
    Nov 25, 2015
    Messages:
    53
    Likes Received:
    14
    Location:
    Tempe, AZ
    Yes, switched the ignition on & off this morning and still getting the same message.
     
  4. kiwi dave

    kiwi dave GT Reference

    Joined:
    Oct 28, 2008
    Messages:
    1,799
    Likes Received:
    245
    Location:
    Auckland, New Zealand
    It would be nice to know the error code(s), but since you don't have any diagnostic equipment, I can't advise where you should start to look. Perhaps a dealer is your only option as it stands.

    When the "SERVICE" icon appeared on my 1400 Custom a year or so ago, it took me six weeks to find the problem. In my case it was a clutch switch issue, and despite knowing the error code (P0745), it was not listed in the service manual or available from any dealers that I asked.

    If everything else appears to be in order, it might be worth a try to check this switch. Note it is a single pole, double throw type, so you need to check both sides of the switch.
     
  5. Glenn Thorpe

    Glenn Thorpe Tuned and Synch'ed

    Joined:
    Nov 25, 2015
    Messages:
    53
    Likes Received:
    14
    Location:
    Tempe, AZ
    Kiwi Dave, Thanks for the advice. I'll need to get a tool like the TR Alaris to read error codes.

    After I got home from work I turned the ignition on and got a "SERVICE" icon without the "URGENT". After starting the bike the "SERVICE " icon went away and no flashing general warning light. Rode around the block and restarted the bike several times and the problem did not reappear.
    .
    I'm happy it's back to normal but it will be hard to have the dealer diagnose & fix it under warranty without the issue present.

    I'll remember to check the clutch switch if this happens again and I get a P0745. I read another post about a "SERVICE URGENT" issues with error code P0155 that turned out to be caused by a loose TPS terminal.
     
  6. Glenn Thorpe

    Glenn Thorpe Tuned and Synch'ed

    Joined:
    Nov 25, 2015
    Messages:
    53
    Likes Received:
    14
    Location:
    Tempe, AZ
    Since my last post the error went away and didn't reappear until a few weeks ago. I get the "URGENT SERVICE" warning with flashing red light and sometimes just "SERVICE" with steady red light. It will go usually away after tuning the ignition on/off a few times and the bike runs great.

    I read the stored codes and got P0155 and P0611. I was able to clear the P0155 but the P0611 wouldn't clear even when the bike is running well without a "SERVICE" message.

    Does anyone know what the codes indicate? is there a likely culprit I should be checking on?
     
  7. kiwi dave

    kiwi dave GT Reference

    Joined:
    Oct 28, 2008
    Messages:
    1,799
    Likes Received:
    245
    Location:
    Auckland, New Zealand
    P0155 -Throttle Grip Position Redundancy tracks C-D inconsistent signal

    P0611 -Data File Saved (for safety) Filled

    I'm suspecting it might be in the throttle itself. The later models are different than what I am familiar with, so I'm not much help. Hopefully, others might chime in.
     
  8. V700Steve

    V700Steve High Miler GT Contributor

    Joined:
    Dec 8, 2008
    Messages:
    629
    Likes Received:
    206
    Location:
    Atlanta area, GA
    OK, here ya go, the P0155 could be a fluke, you can get this by not waiting for the ECU to read the throttle sensor numbers when you turn the key to on.
    The P0611 will stay until the data in the file is downloaded. Quote from service manual---
    Deletion enabled only if the file is downloaded after setting KEY ON.

    From what I read, you have to wait 3 seconds after turning key on to start the bike OR watch the tail lite, it comes on after ECU check.

    Go to your dealer and he'll download the file, it will say what happened in the file. Hopefully the dealer knows how to use PADS and has it all updated.

    If you want to understand your bike better get a service manual, it's in the download section here.
     
    Last edited: Dec 22, 2018
  9. Glenn Thorpe

    Glenn Thorpe Tuned and Synch'ed

    Joined:
    Nov 25, 2015
    Messages:
    53
    Likes Received:
    14
    Location:
    Tempe, AZ
    Yes, I've thought that it could also be a fluke. I first got the "service urgent" warning in May on and off for a few weeks, then didn't see it again until a few weeks ago and it's happening intermittently.

    The "service urgent" warning only appears when tuning the ignition on. It's never comes on when the bike is running normally.

    The "service urgent" warning will go away only after turning the ignition off and then on again - eventually. It may take several cycles to reset.

    The bike runs great when no warning is appearing.

    I wish I knew how to get rid of this issue. Other than this the bike is fantastic.
     
  10. crzrdave

    crzrdave Just got it firing!

    Joined:
    Dec 23, 2014
    Messages:
    17
    Likes Received:
    7
    Location:
    Lakewood, CA
    My bike, a 2014 California Touring, had the same problem as my buddy and I were heading into New Mexico. Fortunately, my service light cleared after several restarts but it was still acting up. There are no Guzzi dealers in New Mexico so I contacted Powersports Outlet in Prescott AZ. They tried to help me over the phone but I ended up bringing it in. Matt at Powersports ran a diagnostics (PADS) and it turned out that at my last service, the shop in Long Beach overfilled my oil. The oil got into the airbox, saturated the filter, and fouled the sensor. Powersports got me back on the road in no time. So, if you still need a reputable shop, I highly recommend this shop.
     
  11. GT-Rx®

    GT-Rx® Administrator Staff Member

    Joined:
    Jul 1, 2009
    Messages:
    10,414
    Likes Received:
    2,691
    Location:
    Malibu
    Guzzi Classics?
    Did you know you are just about as close to my shop in Orange? We know modern Guzzi better than almost every dealer; https://gtmotocycles.com/pages/service

    Look forward to helping you next.

    Merry/Happy.
     
  12. Glenn Thorpe

    Glenn Thorpe Tuned and Synch'ed

    Joined:
    Nov 25, 2015
    Messages:
    53
    Likes Received:
    14
    Location:
    Tempe, AZ
    Thanks for the tip. Since there is no longer a Guzzi dealer in the Phoenix area I was thinking about taking it up to Prescott if this problem persists.
     
  13. kiwi dave

    kiwi dave GT Reference

    Joined:
    Oct 28, 2008
    Messages:
    1,799
    Likes Received:
    245
    Location:
    Auckland, New Zealand
    Overfilling the engine oil caused the SERVICE light to come on? I'd be curious to know what code was presented to PADS.
     
  14. crzrdave

    crzrdave Just got it firing!

    Joined:
    Dec 23, 2014
    Messages:
    17
    Likes Received:
    7
    Location:
    Lakewood, CA
    The error code was P0217, sensor pressure dif. error.
     
  15. crzrdave

    crzrdave Just got it firing!

    Joined:
    Dec 23, 2014
    Messages:
    17
    Likes Received:
    7
    Location:
    Lakewood, CA
    I'll be checking out your shop for my next service. Thanks for the info.
     
  16. kiwi dave

    kiwi dave GT Reference

    Joined:
    Oct 28, 2008
    Messages:
    1,799
    Likes Received:
    245
    Location:
    Auckland, New Zealand
    Interesting, thanks for that. I have error code P0217 listed as "Manifold pressure too low error (signal not valid)". I assume we're talking about the same sensor. Did the excess oil saturate the air filter in the manifold?
     
  17. V700Steve

    V700Steve High Miler GT Contributor

    Joined:
    Dec 8, 2008
    Messages:
    629
    Likes Received:
    206
    Location:
    Atlanta area, GA
    Sometimes sensors go bad and it's not a fluke. You could always get an aftermarket warranty if you don't want to buy a part.
     
  18. crzrdave

    crzrdave Just got it firing!

    Joined:
    Dec 23, 2014
    Messages:
    17
    Likes Received:
    7
    Location:
    Lakewood, CA
    Yes; they had to replace the air filter. In all, they removed about a half cup of oil including what was removed from the air box.
     
  19. Glenn Thorpe

    Glenn Thorpe Tuned and Synch'ed

    Joined:
    Nov 25, 2015
    Messages:
    53
    Likes Received:
    14
    Location:
    Tempe, AZ
    I still haven't figured out the cause of the "SERVICE URGENT" error code. It had been intermittent, only appearing every few months.

    Lately there is a definite pattern.
    1). After starting the bike to go to work it shows "SERVICE URGENT", red light flashing and in limp mode.
    2). turn off the ignition and restart it, then it shows "SERVICE" with steady on red light, ride to work (not on limp mode).
    3). Get to work then turn the ignition off and on again, restart and "SERVICE" shows for a few seconds then goes away and all is good.

    I consistently get a P0155 code.

    Any advice on what could be wrong?

    We lost the last Guzzi dealer in Phoenix last summer while the bike was still under warranty and I just haven't had time to bring it to the dealers in Tucson or Prescott since then.
     
  20. Roose

    Roose Tuned and Synch'ed

    Joined:
    Oct 5, 2018
    Messages:
    39
    Likes Received:
    15
    Location:
    Cincinnati
    I'm no wrench, so take this as simple advice. It's probably going to be costly either way. I'd rather spend it on knowing the actual failure. I'd be curious if the ECU is good? Based on no physical issues present, oil, water etc. You've laid out a cycle for each time you're riding. To me that means the ECU isn't processing new data, until electricity is cut and re-applied. I'd pull the diags, diagnosis them or have them reviewed by knowledgeable MG wrench, go forward with their discovery or possibly look at re-flashing the ECU. My 2 cents, the ECU firmware/software is corrupted. If the same issues occur after the flash, fall back to the wrench recommendation(s).
     

Share This Page