Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! There is zero tolerance on personal attacks and off-site links to other Forums or competing products. Also be sure to click on the STORE link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. And if you haven't seen our MotoCycle (not) art, click on the BUILDS tab above to see our work at our sister business; GT MotoCycles® -- WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.

Low RPM fuelling issue

Discussion in 'Cal 1400 8V' started by Skipper, Aug 12, 2017.

  1. Skipper

    Skipper Tuned and Synch'ed

    Joined:
    Jul 10, 2014
    Messages:
    41
    Likes Received:
    8
    Location:
    Brisbane, Australia
    I've had the full fuelling upgrade for 2 years now with no issues.
    However for the last month have experienced major hesitation at low revs, particularly upon take off from traffic lights.
    This problem only occurs after approx 15-20 minutes of riding. Requires a good screw of the throttle to clear and occasionally slipping the clutch to keep revs up. I've been advised by a specialist that Power Commanders can drop their program after a couple of years.
    4 tanks of different brand fuel have been tried.
    Any similar experiences or feedback?
     
  2. kiwi dave

    kiwi dave GT Reference

    Joined:
    Oct 28, 2008
    Messages:
    2,071
    Likes Received:
    357
    Location:
    Auckland, New Zealand
    I take it you didn't back up your power commander maps? If you did, restore them.

    It could also be your Autotune. Try clearing the settings in this, and start again. I've done this on a few occasions.
     
  3. GTM®

    GTM® Administrator Staff Member GT di Razza Pura

    Joined:
    Jul 1, 2009
    Messages:
    11,664
    Likes Received:
    3,819
    Location:
    Malibu
    Well, don't know who this specialist is, but they have no idea what they're talking about.
    Pull and send me the PC-V map. While it is a dynamic system, it does need touch ups by me at every service or annually.
     
  4. Touringman

    Touringman Cruisin' Guzzisti

    Joined:
    May 2, 2014
    Messages:
    163
    Likes Received:
    43
    Location:
    Red Oak TX
    OK...I admit it. I am a luddite when it comes to computers maps loading and downloading...Todd, do you have a tutorial somewhere on the site for the computer illiterate, or know where one is so I can send you my map for an update...which I have never done.
    Kirk
     

Share This Page