Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! There is zero tolerance on personal attacks and off-site links to other Forums or competing products. Also be sure to click on the STORE link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. And if you haven't seen our MotoCycle (not) art, click on the BUILDS tab above to see our work at our sister business; GT MotoCycles®-- WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.

Need some help for a 1980 V50II

Discussion in 'Small Block' started by Mark Emig Blacksmith, Aug 28, 2017.

  1. Mark Emig Blacksmith

    Mark Emig Blacksmith Just got it firing!

    Joined:
    Aug 27, 2017
    Messages:
    4
    Likes Received:
    0
    Location:
    Hurley, NY65,2
    Hello all,
    I am starting to bring my Fathers 1980 V50II back to life. It was sitting in his garage for about 20 (yes 20) years. Carbs were completely gummed up. Cleaned/freed up carbs. Ran a compression test, 138 right side, 132 left. Went to start with a new battery, turned over well at first. Now the relay right in front of the battery clicks, and the starter doesn't turn. I can see the relay work, and there is a green light inside it also, but no noise from the starter. Can anyone give me some ideas? I am handy with a wrench, but not a diagnostician....
    Thank you.
     
  2. john zibell

    john zibell Moderator Staff Member GT di Razza Pura

    Joined:
    Oct 28, 2008
    Messages:
    7,839
    Likes Received:
    788
    Location:
    Huntsville, AL
    Are you getting 12 volts to the wire at the spade terminal on the solenoid when you press the start button?
     
  3. Brian UK

    Brian UK GT Reference

    Joined:
    Nov 6, 2008
    Messages:
    2,000
    Likes Received:
    182
    Location:
    Addlestone, Surrey, UK
    Don't recall any green lights.
    But the Startus Interruptus wiring mod applies to the V50 the same as the new models. But first check as John suggests. Then pull the wire off that spade terminal on the solenoid and bridge from the top main terminal to that spade with a metal bar or screwdriver which should get the starter whirring. If it doesn't you have a faulty solenoid probably.
     
  4. not-fishing

    not-fishing Cruisin' Guzzisti GT Famiglia

    Joined:
    Oct 23, 2012
    Messages:
    175
    Likes Received:
    17
    Location:
    Folsom, CA
    Also if the V50 sat outside for long water collects in the bottom of the starter, the iron rotor rusts and collects on the bottom of the starter. It will start when cold but once the engine heats up the starter locks up. The fix is a new starter.

    Don't ask me how I know.
     
    Mark Emig Blacksmith likes this.
  5. Mark Emig Blacksmith

    Mark Emig Blacksmith Just got it firing!

    Joined:
    Aug 27, 2017
    Messages:
    4
    Likes Received:
    0
    Location:
    Hurley, NY65,2
    I will check that. Thank you for the help.
     

Share This Page