Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! There is zero tolerance on personal attacks and off-site links to other Forums or competing products. Also be sure to click on the STORE link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. And if you haven't seen our MotoCycle (not) art, click on the BUILDS tab above to see our work at our sister business; GT MotoCycles® -- WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.

Quick release fuel line connector

Discussion in 'Chat & Tech Info' started by David Powell, Jan 24, 2020.

  1. David Powell

    David Powell 2009 Norge 1200 GT Contributor

    Joined:
    Jun 15, 2015
    Messages:
    51
    Likes Received:
    15
    Location:
    Huffman, TX
    I can hear it pumping up and the bike will start every now and then for some reason. In fact, i went to load test the battery today. I clipped the voltmeter onto the battery. 13.4v. I hit the ignition and then the start button. It started. The voltmeter indicated the min voltage was 10.2V while spinning the engine. The injector on the left side was just hanging there pointed at the port. Not bolted in. I pushed the injector in and the running smoothed out. turned it off and now it won't restart.
    I did take the battery to load test. It FAILED. I have a new one in my truck now to try this evening. The fine folks at batteries plus warrantied the battery.
    I will keep posting results. I'm not relenting.
     
  2. David Powell

    David Powell 2009 Norge 1200 GT Contributor

    Joined:
    Jun 15, 2015
    Messages:
    51
    Likes Received:
    15
    Location:
    Huffman, TX
    I checked all of the fuses and do frequently during this ordeal. I can hear the relays clicking. And the crazy thing started while checking the voltage drop at startup. Now won't restart.
     
  3. David Powell

    David Powell 2009 Norge 1200 GT Contributor

    Joined:
    Jun 15, 2015
    Messages:
    51
    Likes Received:
    15
    Location:
    Huffman, TX
    Thanks for identifying the relay. I'm going to label the female plug with the purpose for each.
     
  4. scottmastrocinque

    scottmastrocinque Scott Mastrocinque GT Famiglia

    Joined:
    Jun 26, 2011
    Messages:
    1,012
    Likes Received:
    692
    Location:
    Findlay, Ohio
    I’m fat, not dumb...

    Watch the overwhelming number of your problems disappear. I strongly suggest you drain the capacitors like I previously posted by connecting the battery cables together, before you install the new battery.

    Good Luck!

    FBE0F53B-80B2-47E3-9413-B765C2AFE170.png
     
  5. V700Steve

    V700Steve High Miler GT di Razza Pura

    Joined:
    Dec 8, 2008
    Messages:
    941
    Likes Received:
    345
    Location:
    Atlanta area, GA
    Finally getting somewhere.

    This is the kinda stuff makes ya want a drink.
     
    Last edited: Jan 27, 2020
  6. David Powell

    David Powell 2009 Norge 1200 GT Contributor

    Joined:
    Jun 15, 2015
    Messages:
    51
    Likes Received:
    15
    Location:
    Huffman, TX
    Ha Ha yes it is... It did not start when i put the new battery in. I decided to take the relays all out again and just re-clean the contacts and shuffle them around a bit. Now it starts and everything works except the low beams.
    I received notice that my new relays are being shipped so my troubles should be over. The great thing about all this is all of the contacts and connectors are clean and tight. I know where everything is, I now know a simple trick to get the fuel line off. I am good at getting the plastic now. It's got new CPS and oil pressure sensor.
    I can ride somewhere and have a drink...
     
    scottmastrocinque and V700Steve like this.
  7. john zibell

    john zibell Moderator Staff Member GT di Razza Pura

    Joined:
    Oct 28, 2008
    Messages:
    8,118
    Likes Received:
    909
    Location:
    Huntsville, AL
    I suggest you take a car or drink at home. Alcohol and motorcycles don't mix.
     
    David Powell likes this.
  8. David Powell

    David Powell 2009 Norge 1200 GT Contributor

    Joined:
    Jun 15, 2015
    Messages:
    51
    Likes Received:
    15
    Location:
    Huffman, TX
    Thank you brother. I don't drink and ride.
     
  9. David Powell

    David Powell 2009 Norge 1200 GT Contributor

    Joined:
    Jun 15, 2015
    Messages:
    51
    Likes Received:
    15
    Location:
    Huffman, TX
    So, now the only thing that is not working is the low beams.
     
  10. scottmastrocinque

    scottmastrocinque Scott Mastrocinque GT Famiglia

    Joined:
    Jun 26, 2011
    Messages:
    1,012
    Likes Received:
    692
    Location:
    Findlay, Ohio
    Fused relay(s) from low voltage “bouncing”. New relays and you should be good to go.
     
    V700Steve likes this.
  11. David Powell

    David Powell 2009 Norge 1200 GT Contributor

    Joined:
    Jun 15, 2015
    Messages:
    51
    Likes Received:
    15
    Location:
    Huffman, TX
    Scott, from what i've learned, and tell me if im off base. The low beams will not come on when the alternator is not charging. ??
    The alternator is not charging and low beams are not on. Will the new relays (arriving tomorrow) possibly fix this problem?
    I read that i can check the voltage on pin 87 and determine if the alternator is working but not reaching the battery. I will look for that narrative on that. That generator is not charging and it's a New one installed only last year. Probably didn't need it and nothing wrong with the other one. Now that i'm beginning to get an understanding of the bike's logic.
    Looking forward to riding this beauty again.
     
  12. scottmastrocinque

    scottmastrocinque Scott Mastrocinque GT Famiglia

    Joined:
    Jun 26, 2011
    Messages:
    1,012
    Likes Received:
    692
    Location:
    Findlay, Ohio
    I am not aware of that circumstance.

    I check the alternator either by going to the voltage display in the dashboard screen, or by connecting a voltmeter to the battery and raising the rpm of the bike to over 2000. The voltage will climb to somewhere between 13.6-14.2 which indicates the alternator is working fine.
     
    V700Steve likes this.
  13. V700Steve

    V700Steve High Miler GT di Razza Pura

    Joined:
    Dec 8, 2008
    Messages:
    941
    Likes Received:
    345
    Location:
    Atlanta area, GA
    If I remember correctly the Alt wires go directly to a 40A or 30A big fuse under your seat. It's a BIG double fuse rubber hung on a thong. By your relays.
    It won't charge if blown, even some that look good!!
     
  14. David Powell

    David Powell 2009 Norge 1200 GT Contributor

    Joined:
    Jun 15, 2015
    Messages:
    51
    Likes Received:
    15
    Location:
    Huffman, TX
    Scott, the dashboard display indicates the same as the battery, 12.6v but it never changes with rpm and its the same either running or not. I don't have low beam headlights either. From my understanding, that indicates no alternator charging. could it be one of those relays not making contact? The alternator was brand new just a few miles ago. I am going to check the belt if i have time this evening. I don't think the belt is off though. I have a stethoscope and the alternator sound like its spinning. It doesn't sound like it's loaded though.


    Onward through the fog!
     
  15. David Powell

    David Powell 2009 Norge 1200 GT Contributor

    Joined:
    Jun 15, 2015
    Messages:
    51
    Likes Received:
    15
    Location:
    Huffman, TX
    Steve, I see voltage on both sides of all of the fuses. This evening if i get time, i will dig into it again.

    Is that a light i see way down at the end of the tunnel?
     
  16. Nordicnorm

    Nordicnorm Cruisin' Guzzisti GT Contributor

    Joined:
    May 12, 2011
    Messages:
    180
    Likes Received:
    60
    Location:
    Vancouver Island BC
    This advice has saved many elbows from being broken, including my B-11. It has been posted by John several times over the years.
    May I suggest it is made into a "sticky"?
     
    tillyz and David Powell like this.
  17. David Powell

    David Powell 2009 Norge 1200 GT Contributor

    Joined:
    Jun 15, 2015
    Messages:
    51
    Likes Received:
    15
    Location:
    Huffman, TX
    I am a better person... thanks to all of you folks that have been so kind as to offer your comments and suggestions.
    Drawn from deep experience im sure. My Norge is happy I again. Those relays finally arrived today and i carefully labeled each plug and replaced each relay, testing as it went along. I now have low beams, high beams, alternator charging, starts, idles perfectly and i know a lot more about my very fine Guzzi. I went for a ride and wow, sounds great and runs great. I want to say thank you to you all.
     
  18. Raven

    Raven High Miler GT Famiglia

    Joined:
    Jul 3, 2017
    Messages:
    547
    Likes Received:
    268
    Location:
    Lac Ste. Marie, Qc
    Fantastic news!
     
    David Powell likes this.
  19. kiwi croc

    kiwi croc Tuned and Synch'ed

    Joined:
    Apr 8, 2011
    Messages:
    53
    Likes Received:
    8
    Location:
    Greymouth NZ
    Well done.
     
    David Powell likes this.
  20. scottmastrocinque

    scottmastrocinque Scott Mastrocinque GT Famiglia

    Joined:
    Jun 26, 2011
    Messages:
    1,012
    Likes Received:
    692
    Location:
    Findlay, Ohio
    Excellent. I’m thrilled for you. Enjoy your Norge.

    You’re welcome.
     
    David Powell likes this.

Share This Page