• Ciao Guest - You’ve landed at the ultimate Guzzi site. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER - Use the CONTACT above if you need help. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have, have likely been already answered. DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back in and reply within 24 hours, or your post will be deleted. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! Be sure to see our STORE link also above for our 700+ product inventory, including OEM parts and many of our 100% Made-in-SoCal-USA GTM products and engine kits. In SoCal? Click the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work, and don't miss our GT MotoCycles® (not) art on the BUILDS tab above. WE'RE HERE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED - DO NOT EMAIL AND ASK QUESTIONS OR ASK TO CALL YOU.
  • There is ZERO tolerance on personal attacks and ANY HYPERLINKS to PRODUCT(S) or other competing website(s), including personal pages, social media or other Forums. This ALSO INCLUDES ECU DIAGnostic software, questions and mapping. We work very hard to offer commerically supported products and to keep info relevant here. First offense is a note, second is a warning, third time will get you banned from the site. We don't have the time to chase repeat (and ignorant) offenders. This is NOT a social media platform; It's an ad-free, privately funded website, in small help with user donations. Be sure to see our online STORE link above; ALL product purchases help support the site, or you can upgrade your Forum profile or DONATE via the link above.
  • Like the new V100, GuzziTech is full throttle into the future! We're now running on an all-new server and we've updated our Forum software. The visual differences are obvious, but hopefully you'll notice the super-fast speed. If you notice any glitches or have any issues, please post on the Site Support section at the bottom. If you haven't yet, please upgrade your account which is covered in the Site Support section or via the DONATE tab above, which gives you full site access including the DOWNLOADS section. We really appreciate every $ and your support to keep this site ad-free. Create an account, sign in, upgrade your account, and enjoy. See you on the road in 2022.

TPS reset killed my heated grips

Mayakovski

High Miler
GT Famiglia
Joined
Dec 17, 2017
Messages
861
Location
Comox, BC, CANADA
Morning;

In preparation for my 5500KM road trip through BC, Alberta and SK (leaving today) I did the TPS reset last night using my GTM flash tool. I fired her up afterwards and tested the throttle, and the reset worked fine and the throttle is back to being nice and smooth.

But this morning when I left my place my new Koso heated grips are dead. I checked the wiring and fuses and everything is perfect. But the grips are dead. Help!

Suggestions?
 

Mayakovski

High Miler
GT Famiglia
Joined
Dec 17, 2017
Messages
861
Location
Comox, BC, CANADA
Completely independent, and no way possible for the TPS reset to do anything to a wiring circuit. My suggestion is to trace the wiring.
I did not really think they were connected but it is a heck of a coincidence. The grips have been aces for the last few weeks. Then TPS reset, and boom, no grips. I'll try and trace it out tomorrow in Vancouver.
 

kiwi dave

GT Reference
Joined
Oct 28, 2008
Messages
2,221
Location
Auckland, New Zealand
I have Koso heated grips on my 2017 Indian Chief. I do like the integrated controller built into the left hand grip, sometimes it gets busy to find a place to mount a controller.

They work well, but with one button I have to toggle right through the various heat settings if I wish to reduce the heat by one notch. Not really a gripe, just an observation.

I would be checking all fuses before doing anything else. It's bound to be that simple.
 

DeadEye

GT Reference
GT di Razza Pura
Joined
Jun 13, 2020
Messages
1,408
Location
Eastern Ontario - Western Quebec
Did you * fiddle * with the battery terminals when attaching the clips for the tool ?
It they are getting no power - its could be at the source ?
Have a Awesome trip !

PS: If you see a Bronze Ford Escape with Ontario plates - wave. Its my brother...
They are on a road trip out West, they hit Alberta Yesterday.
 
Top