• Ciao Guest - You’ve landed at the ultimate Guzzi site. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER - Use the CONTACT above if you need help. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have, have likely been already answered. DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back in and reply within 24 hours, or your post will be deleted. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! Be sure to see our STORE link also above for our 700+ product inventory, including OEM parts and many of our 100% Made-in-SoCal-USA GTM products and engine kits. In SoCal? Click the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work, and don't miss our GT MotoCycles® (not) art on the BUILDS tab above. WE'RE HERE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED - DO NOT EMAIL AND ASK QUESTIONS OR ASK TO CALL YOU.
  • There is ZERO tolerance on personal attacks and ANY HYPERLINKS to PRODUCT(S) or other competing website(s), including personal pages, social media or other Forums. This ALSO INCLUDES ECU DIAGnostic software, questions and mapping. We work very hard to offer commerically supported products and to keep info relevant here. First offense is a note, second is a warning, third time will get you banned from the site. We don't have the time to chase repeat (and ignorant) offenders. This is NOT a social media platform; It's an ad-free, privately funded website, in small help with user donations. Be sure to see our online STORE link above; ALL product purchases help support the site, or you can upgrade your Forum profile or DONATE via the link above.
  • Like the new V100, GuzziTech is full throttle into the future! We're now running on an all-new server and we've updated our Forum software. The visual differences are obvious, but hopefully you'll notice the super-fast speed. If you notice any glitches or have any issues, please post on the Site Support section at the bottom. If you haven't yet, please upgrade your account which is covered in the Site Support section or via the DONATE tab above, which gives you full site access including the DOWNLOADS section. We really appreciate every $ and your support to keep this site ad-free. Create an account, sign in, upgrade your account, and enjoy. See you on the road in 2022.

V7 Registry & Picture thread -- ADD YOUR BIKE

GTM®

Administrator
Staff member
GT di Razza Pura
Joined
Jul 1, 2009
Messages
12,945
Location
Malibu
V7STONE AN 2021 ZGUKZUA03MM000123
Unfortunately dealing with a few issues with the bike. It's currently at the dealership.
Congrats, thanks for posting, and sorry to hear. What issues are you having?
 

radioheadmike

Tuned and Synch'ed
Joined
May 7, 2021
Messages
40
Location
Toronto
Congrats, thanks for posting, and sorry to hear. What issues are you having?

Thank you!

I have the list here that I put together for the service team:

1. Takes forever to get the engine fired (mornings or on a cold start). It churns, revs, then stalls (likely related to the EVAP system?)

2. In slow speed, erratic & dangerous fueling , revs up to 2,000 – 3000 RPM during stop and go traffic (check if the throttle is sticky)

3. Check Engine – kicked in the first 100 kms of riding , same day I picked up the bike from the dealership.

4. Fuel tank cap is so pressurized when removing it. Makes a woosh/suction noise

5. Once the bike is running, it is very smooth, no issues. Rides nicely on the highway or in non stop-and-go traffic.
 

Xtrythis1

Tuned and Synch'ed
GT Contributor
Joined
May 15, 2021
Messages
39
Location
Houston
Thank you!

I have the list here that I put together for the service team:

1. Takes forever to get the engine fired (mornings or on a cold start). It churns, revs, then stalls (likely related to the EVAP system?)

2. In slow speed, erratic & dangerous fueling , revs up to 2,000 – 3000 RPM during stop and go traffic (check if the throttle is sticky)

3. Check Engine – kicked in the first 100 kms of riding , same day I picked up the bike from the dealership.

4. Fuel tank cap is so pressurized when removing it. Makes a woosh/suction noise

5. Once the bike is running, it is very smooth, no issues. Rides nicely on the highway or in non stop-and-go traffic.

Yikes that sounds scary... I'd also tell Customer service that's straight up dangerous.
 

radioheadmike

Tuned and Synch'ed
Joined
May 7, 2021
Messages
40
Location
Toronto
Yikes that sounds scary... I'd also tell Customer service that's straight up dangerous.
Yup made sure to emphasis this. Basically I am at stop light idling around normal 1200-1500 RPM, and then it would just rev up (without touching the throttle) to about 3000 RPM :shake:. Not fun when I start letting go of the clutch.
 

GTM®

Administrator
Staff member
GT di Razza Pura
Joined
Jul 1, 2009
Messages
12,945
Location
Malibu
2021 V7 Stone 850 Centenario
ZGUKZUA00MM000077
Purchased May 1, 2021
Thanks for posting your info and pic! U.S. is too vague, so just a state if you're too paranoid about listing your city, all good. ;)
Hope to see you here posting often.
 

Scuderia_Jedi

Just got it firing!
Joined
Jun 14, 2021
Messages
8
Location
Florida
Thanks for posting your info and pic! U.S. is too vague, so just a state if you're too paranoid about listing your city, all good. ;)
Hope to see you here posting often.

My bad on the vague location. Noob mistake!

I am paranoid, but I like to think of it as a healthy dose if that’s possible haha! I’ll update my location in my profile. I’m in Florida in any case (hopefully not for too much longer haha).
 

ValerioGuzzi

Tuned and Synch'ed
Joined
Nov 7, 2020
Messages
35
Location
London
Um, I see a krytonite lock on the wheel,.
what’s on the seat ?

Otherwise nice, I like the earlier side covers...

Thanks Man!

yeah and a Kryptonite lock round the front wheel chained to a ground Anchor, you can never be too careful in London.

That is a battery optimiser, I should have probably removed it for the pic haha..
 

Xtrythis1

Tuned and Synch'ed
GT Contributor
Joined
May 15, 2021
Messages
39
Location
Houston
View attachment 22591 First Guzzi and first motorcycle. Bought over The Weeknd in Charlotte, North Carolina and brought home to Virginia. She’s beautiful.

2020 Stone S (#263)
VIN: ZGULDU029LM000230
Nice! I'm #330 I really hope you don't have the rear main seal issues a couple of us have had on our Stone S... Also is your speedo in MPH or KMH?
 

msutherland29

Just got it firing!
Joined
May 30, 2021
Messages
24
Location
Fredericksburg, VA
Nice! I'm #330 I really hope you don't have the rear main seal issues a couple of us have had on our Stone S... Also is your speedo in MPH or KMH?

I hope not either, it was on my mind when I was deciding on purchasing.

Spedo is in MPH, but the dealer I bought it from had two S models on the floor, the other was in Kilometers, thought that was strange.
 

Dino Rossetti

Just got it firing!
Joined
Sep 13, 2018
Messages
14
Location
n/a
Thank you!

I have the list here that I put together for the service team:

1. Takes forever to get the engine fired (mornings or on a cold start). It churns, revs, then stalls (likely related to the EVAP system?)

2. In slow speed, erratic & dangerous fueling , revs up to 2,000 – 3000 RPM during stop and go traffic (check if the throttle is sticky)

3. Check Engine – kicked in the first 100 kms of riding , same day I picked up the bike from the dealership.

4. Fuel tank cap is so pressurized when removing it. Makes a woosh/suction noise

5. Once the bike is running, it is very smooth, no issues. Rides nicely on the highway or in non stop-and-go traffic.


For #2, Check your Engine temp sensor. I had that issue it was this sensor. Hook it up to Diag to see what the Engine temp is reading. For#4 Do the evap delete here on Guzzitech/store. For #1 check your Spark plug caps either replace the caps/or switch to NGK red wires might need different plugs tho.
 

radioheadmike

Tuned and Synch'ed
Joined
May 7, 2021
Messages
40
Location
Toronto
For #2, Check your Engine temp sensor. I had that issue it was this sensor. Hook it up to Diag to see what the Engine temp is reading. For#4 Do the evap delete here on Guzzitech/store. For #1 check your Spark plug caps either replace the caps/or switch to NGK red wires might need different plugs tho.

It was indeed the Engine Temp Sensor. The dealership replaced it and no more issues with the bike. They said item 4 is normal and by design. I'll likely do the evap delete after the warranty expires.
 
Top