Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! There is zero tolerance on personal attacks and off-site links to other Forums or competing products. Also be sure to click on the STORE link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. And if you haven't seen our MotoCycle (not) art, click on the BUILDS tab above to see our work at our sister business; GT MotoCycles®-- WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.

a way to test ignition boxes???

Discussion in 'Small Block' started by redwitch, Sep 6, 2018.

  1. redwitch

    redwitch Tuned and Synch'ed

    Joined:
    Oct 9, 2015
    Messages:
    36
    Likes Received:
    4
    Location:
    france
    Hello everybody

    I shave trouble with my newly reborn V75. It had a misfire on the left cylinder, and it got worse, untill no spark at all! I have checked the HT leads, coils, wires, and now suspect the " black box " It is a Motoplat ignition. anybody with a sure way to detect a failure in these components? I checked the Ohms on both boxes, and it is about 9000 ( if meter is correct ) any other way?????????
    thanks for any tips. The bike runs great when it runs, and I would like to ride irt more before cold winter comes...

    thanks, and all the best to Guzzi fans
     
  2. Dr. Jake

    Dr. Jake Just got it firing!

    Joined:
    Jul 18, 2018
    Messages:
    23
    Likes Received:
    1
    Location:
    Copenhagen, Denmark
    I'm sure you changed the sparkplugs first even though you didn't say so ;)

    Otherwise I would do standard black box test, i.e. switch suspect component but nothing else to other cylinder and see if problem also changes side

    Disclaimer: I have no first hand experience with motoplats

    Good luck

    Jake
     
  3. redwitch

    redwitch Tuned and Synch'ed

    Joined:
    Oct 9, 2015
    Messages:
    36
    Likes Received:
    4
    Location:
    france
    Hi Jake. thank you for help. I did all the checks and isolated coils first and then the boxes. doing so, I cleaned and changed somme connections, and , it seems to have done the trick. probably a gremlin in some of these old wires. I did not change it all, since they looked " clean enough…" Good lesson, on a 30 years old bike, nothing is perfect…. But, it works OK now, and I did a nice ride this afternoon. After some dull days checking wires and all that, it seemed very pleasant. Thanks, and best regards. Hervé
     
  4. Dr. Jake

    Dr. Jake Just got it firing!

    Joined:
    Jul 18, 2018
    Messages:
    23
    Likes Received:
    1
    Location:
    Copenhagen, Denmark
    Glad it worked out for you
     

Share This Page