Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! There is zero tolerance on personal attacks and off-site links to other Forums or competing products. Also be sure to click on the STORE link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. And if you haven't seen our MotoCycle (not) art, click on the BUILDS tab above to see our work at our sister business; GT MotoCycles®-- WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.

MGCT and ABS Blink and Speedo Swings

Discussion in 'V7/V85/V9 Chat & Tech' started by Mayakovski, Sep 24, 2020.

  1. Mayakovski

    Mayakovski High Miler GT Famiglia

    Joined:
    Dec 17, 2017
    Messages:
    603
    Likes Received:
    236
    Location:
    Comox, BC, CANADA
    Morning All;

    This morning on the way to work my V7 III Anniversario decided to play funny with the dash lights.

    Every 20 to 30 seconds the MGCT and ABS lights will blink and the speedo will swing up to 200 kmph. The bike runs just fine, no issues at all, just the lights and the speedo. Does not matter how fast I am going or whether I am accelerating or steady on the throttle. It has never done this before.

    From what I can see it looks like I may have to do the MGCT calibration.
    I did have a new rear tire installed a few weeks ago, but have ridden about 500KM since then without issue.

    Suggestions?
    Thanks
     
  2. acidlaser

    acidlaser Just got it firing!

    Joined:
    Jun 24, 2017
    Messages:
    17
    Likes Received:
    18
    Location:
    Los Angeles, CA
    Might check the speed sensor cable near the wheel. A couple years ago my V9 did this sporadically before the speedometer stopped working entirely. Turns out the cable was loose and rubbing on the brake rotor, which chewed through the insulation and shorted it out.
     
    Mayakovski likes this.
  3. Mayakovski

    Mayakovski High Miler GT Famiglia

    Joined:
    Dec 17, 2017
    Messages:
    603
    Likes Received:
    236
    Location:
    Comox, BC, CANADA
    Will look at that tonight. Thanks.
     
  4. vagrant

    vagrant High Miler GT Contributor

    Joined:
    Aug 2, 2009
    Messages:
    872
    Likes Received:
    378
    Location:
    Gainesville, Ga. or Green Valley Az.
    check your tire pressure too
     
    Mayakovski likes this.
  5. Mayakovski

    Mayakovski High Miler GT Famiglia

    Joined:
    Dec 17, 2017
    Messages:
    603
    Likes Received:
    236
    Location:
    Comox, BC, CANADA
    Will do. I'm going to turn MGCT off for the ride home and see if I still get the blinks and speedo sweep. Should help narrow down what is happening.
     
  6. Mayakovski

    Mayakovski High Miler GT Famiglia

    Joined:
    Dec 17, 2017
    Messages:
    603
    Likes Received:
    236
    Location:
    Comox, BC, CANADA
    OK, I have checked the tire pressures. Made sure the cables are all clear and fine. Made sure the ABS sensors are clean and unblocked and I cannot complete the recalibration.

    I have followed the steps in the manual, but after accelerating to 30km/h in 2nd for 8 seconds the MGCT light does not go out. IT stays lit no matter how long I ride like that. Only turning off the bike turns out that light.

    I have done this numerous times, following the instructions exactly and the procedure will not complete.

    Any other suggestions before I take it in for warranty work?
    Thanks
     
  7. Mayakovski

    Mayakovski High Miler GT Famiglia

    Joined:
    Dec 17, 2017
    Messages:
    603
    Likes Received:
    236
    Location:
    Comox, BC, CANADA
    Got it sorted. A gent on FB suggested unplugging the battery for a bit. I did for an hour, and now the issue is resolved and the bike is running even better than before. No more blinking lights or speedo swings, and the motor is running smoother as well. I guess the ECU is like a smartphone, it likes to be reset now and then.
     

Share This Page