Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! There is zero tolerance on personal attacks and off-site links to other Forums or competing products. Also be sure to click on the Store link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. Also be sure to see our GTMotoCycles.com custom BUILDS tab above. WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.

Speed sensor ECU error 56

Discussion in 'BNS12 Chat & Tech' started by NPS, May 14, 2019.

  1. NPS

    NPS Cruisin' Guzzisti GT Contributor

    Joined:
    Dec 11, 2008
    Messages:
    244
    Likes Received:
    35
    Location:
    Churchdown, Gloucester, UK
    I have this error coming up. I looked in the service manual and it specifies a resistance of 500- 600 ohms between the two of the three wires that is not the green earth wire.

    I measured open circuit so got a replacement. When I tested the brand new item the resistance was 20 Mega Ohms. When I connected it to the bike and did a ECU dash error reset, I still got the same error code.

    Could the new item be faulty or something else I havent thought of?
     
  2. V700Steve

    V700Steve High Miler GT di Razza Pura

    Joined:
    Dec 8, 2008
    Messages:
    844
    Likes Received:
    298
    Location:
    Atlanta area, GA
    You may have to go down the road so ecu knows it's working before reset. Just a thought. Speedo work OK?
     
  3. mylovelyhorse

    mylovelyhorse Cruisin' Guzzisti GT Contributor

    Joined:
    Jul 29, 2018
    Messages:
    219
    Likes Received:
    96
    Location:
    Hampshire, UK
    This code was cured on my 2007 Norge by taking it for a very short ride.
     
  4. NPS

    NPS Cruisin' Guzzisti GT Contributor

    Joined:
    Dec 11, 2008
    Messages:
    244
    Likes Received:
    35
    Location:
    Churchdown, Gloucester, UK
    I did ride a few miles and so far the fault has not returned. So OK on the new sensor. Thank you for the comments.
     

Share This Page