Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the Service tab above for the best in service, tires, tuning and installation of our products or custom work. NEW REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - AND PLEASE DON'T BE A DRIVE-BY POSTER: Most questions you may have are well answered on the Forum. As a common courtesy, check back if you are posting elsewhere on the web. There is zero tolerance on personal attacks and off-site links to other Forums or competing products. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free - be courteous. Also be sure to click on the Store link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We are still mostly a one man operation (not Amazon), so thanks in advance for your patience on orders. We do our best to get things out as quickly as possible, and we also aren't in control of things like customs & weather delays, etc. PLEASE refrain from emailing about your order Status, as you will get an email with tracking info when your order goes out; Email inquiries on orders slows everything down. Orders are currently being shipped once or twice a week. You can always sign into the online Store system to check the status. Please refrain if at all possible about emailing for an update; If you must ask for order info, please reply on the actual order email. You will get shipping info when it goes out via our online Store system (check your Spam folder), and if you want to cancel your order, please notify us direct email (do not post or use the Forum) and allow 7-10 business days for a reply BEFORE disputing the charge. We don't want your money if we can't deliver. Special order items are subject to a 15-20% cancellation fee. We cannot answer questions direct unless it’s about something on the Store or that you have purchased from us. We do NOT have a phone number - We are online only - Do not email and tell us to call you. You will find us highly responsive via email on the Contact page with any questions on our products (only). We appreciate the consideration, understanding and your business... past and future. Also be sure to see our GTMotoCycles.com custom BUILDS tab above.

Stelvio, fuel congestion

Discussion in 'Stelvio Chat & Tech' started by GoodKnight, Jun 29, 2019.

  1. GoodKnight

    GoodKnight Just got it firing!

    Joined:
    May 27, 2014
    Messages:
    13
    Likes Received:
    0
    Location:
    Denmark
    Hi again.

    I got a very strange problem with the fuel supply.

    When the fuel level reaches nearly 1/3 the engine starts to congest, and finally shuts down. Turning the key off and on will make it possible to restart, and run for a mile or so - then same happens. Refueling solves it ! And I can run the bike at full power, like going at 120mph.

    I suspect an air leak in the tubing in the tank, or something.....


    /Claus
     
  2. boscoman

    boscoman Tuned and Synch'ed GT Contributor

    Joined:
    Sep 30, 2013
    Messages:
    97
    Likes Received:
    33
    Location:
    Leesburg
    Ok, so you are having a fuel starvation problem. What year is the bike?
    Also are you doing the same mileage as always? Not trusting the gauge I would want to be sure that it isn't reading improperly.
    Next If that is the same as always & the gauge is correct, I would be removing the fuel pump from the tank & be inspecting all the hoses & clamps on it & while it is out be replacing the fuel filter.
    That is where I would begin.
     
    GoodKnight likes this.
  3. GoodKnight

    GoodKnight Just got it firing!

    Joined:
    May 27, 2014
    Messages:
    13
    Likes Received:
    0
    Location:
    Denmark
    Gauge is not the issue, but I'm afraid you're right about the tubes and hoses.

    C/
     
  4. vagrant

    vagrant High Miler GT Contributor

    Joined:
    Aug 2, 2009
    Messages:
    613
    Likes Received:
    211
    Location:
    Gainesville, Ga. or Green Valley Az.
    if it has the dreaded 1/2 plastic gas filter it might be starting to seperate.
     
    GoodKnight and Roose like this.
  5. GoodKnight

    GoodKnight Just got it firing!

    Joined:
    May 27, 2014
    Messages:
    13
    Likes Received:
    0
    Location:
    Denmark
    It is the fuel filter inside the tank that you speak of? - just to be sure

    C/
     
  6. GoodKnight

    GoodKnight Just got it firing!

    Joined:
    May 27, 2014
    Messages:
    13
    Likes Received:
    0
    Location:
    Denmark
    btw - it's a 2012 model
     
  7. GoodKnight

    GoodKnight Just got it firing!

    Joined:
    May 27, 2014
    Messages:
    13
    Likes Received:
    0
    Location:
    Denmark
    Update - it has gone from bad to worse, now it happens even with a full tank. I had a nightmare getting the last 50 miles home this afternoon.

    C/
     
  8. GoodKnight

    GoodKnight Just got it firing!

    Joined:
    May 27, 2014
    Messages:
    13
    Likes Received:
    0
    Location:
    Denmark
    So, there is another version of the fuel filter avaiable?
     
  9. vagrant

    vagrant High Miler GT Contributor

    Joined:
    Aug 2, 2009
    Messages:
    613
    Likes Received:
    211
    Location:
    Gainesville, Ga. or Green Valley Az.
    Go to the store above and do a search for fuel filter. It will show a pic of your Pos and explain everything. Mahle has the one shown and in the Us there are many other choices. You need good hose clamps too.
     
    GoodKnight likes this.
  10. Brian UK

    Brian UK GT Reference

    Joined:
    Nov 6, 2008
    Messages:
    1,951
    Likes Received:
    145
    Location:
    Addlestone, Surrey, UK
    The filter you will have fitted in the tank is the Mahle KL150, what you need is the all metal Mahle KL145 or equivalent.
     
    GoodKnight and john zibell like this.
  11. GoodKnight

    GoodKnight Just got it firing!

    Joined:
    May 27, 2014
    Messages:
    13
    Likes Received:
    0
    Location:
    Denmark
    I opened the tank and found an all metal filter there already.
    Some local guy told me that it could be a problem with the pump micro-relay, I just can't find it.
     
  12. GoodKnight

    GoodKnight Just got it firing!

    Joined:
    May 27, 2014
    Messages:
    13
    Likes Received:
    0
    Location:
    Denmark
    I opened the tank and found an all metal filter there already.
     
  13. GoodKnight

    GoodKnight Just got it firing!

    Joined:
    May 27, 2014
    Messages:
    13
    Likes Received:
    0
    Location:
    Denmark
    65439714_10220036008356580_6540617768784363520_n.jpg
     
  14. boscoman

    boscoman Tuned and Synch'ed GT Contributor

    Joined:
    Sep 30, 2013
    Messages:
    97
    Likes Received:
    33
    Location:
    Leesburg
    I would be inclined to still replace the filter, check to make sure no hose is cracked, & all the wires have good contacts. Without actually looking at it in hand, that's the best I can offer. Anyone else feel to chime in.
     
  15. canuck1969

    canuck1969 GT Reference GT Contributor

    Joined:
    May 31, 2012
    Messages:
    1,242
    Likes Received:
    188
    Location:
    Burlington, Ontario
    I am just going to throw this out there, have you tried running the bike with the gas cap open. Sounds a lot like a plugged vent........just saying.
     
    Brian UK and boscoman like this.
  16. canuck1969

    canuck1969 GT Reference GT Contributor

    Joined:
    May 31, 2012
    Messages:
    1,242
    Likes Received:
    188
    Location:
    Burlington, Ontario
    I thought you said you had a 2012 Stelvio. That is not a fuel pump from a 2012. Looks like a small tank 2011. Is that what you have?
     

Share This Page