• Ciao Guest - You’ve landed at the ultimate Guzzi site. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER - Use the CONTACT above if you need help. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have, have likely been already answered. DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back in and reply within 24 hours, or your post will be deleted. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! Be sure to see our STORE link also above for our 700+ product inventory, including many of our 100% Made-in-SoCal-USA GTM products and engine kits. In SoCal? Click the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work, and don't miss our GT MotoCycles® (not) art on the BUILDS tab above. WE'RE HERE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED - DO NOT EMAIL AND ASK QUESTIONS OR ASK TO CALL YOU.
  • There is ZERO tolerance on personal attacks and ANY HYPERLINKS to PRODUCT(S) or other competing website(s), including personal pages, social media or other Forums. This ALSO INCLUDES ECU DIAGnostic software, questions and mapping. We work very hard to offer commerically supported products and to keep info relevant here. First offense is a note, second is a warning, third time will get you banned from the site. Sorry to have to do this, but we don't have the time to chase repeat (and ignorant) offenders. This is NOT a social media platform; It's an ad-free, privately funded website, in small help with user donations. Be sure to see our online STORE link above; GTM product purchases help support the site, or you can upgrade your Forum profile or DONATE via the link above.
  • Like the new V100, GuzziTech is full throttle into the future! We're now running on an all-new server and we've updated our Forum software. The visual differences are obvious, but hopefully you'll notice the super-fast speed. If you notice any glitches or have any issues, please post on the Site Support section at the bottom. If you haven't yet, please upgrade your account which is covered in the Site Support section or via the DONATE tab above. We really appreciate every $ and your support to keep this site ad-free. Create an account, sign in, upgrade your account, and enjoy. See you on the road in 2022.

Won't start issue (2014 V7 Stone)

axel peemoeller

Just got it firing!
Joined
Aug 21, 2021
Messages
18
Location
New York
I need help please.

Bike is not starting. turns but not starting most of the time.

I changed:
- Battery
- fuel + fuel lines
- injectors
- spark plugs
- had the ecp reset

Checked:
- Spark
- good ground
- fuelpump
- visual check electric
- tank venting
- clean airfilter

with some starter spray it does start after many tries and then runs perfectly. then it tends to start fine but if i don't start for the few days same issue.

ordered new coils and fuel filter. but i am starting to run out of ideas.

Appreciate some knowledge and clues
 

GTM®

Administrator
Staff member
GT di Razza Pura
Joined
Jul 1, 2009
Messages
12,458
Location
Malibu
Please search and read, including the paragraphs in red above... and find the thread on the fuel filter. Odds are if you open the fuel cap, and key on, you'll see fuel swirling. If so, replace the fuel filter.
 

axel peemoeller

Just got it firing!
Joined
Aug 21, 2021
Messages
18
Location
New York
Please search and read, including the paragraphs in red above... and find the thread on the fuel filter. Odds are if you open the fuel cap, and key on, you'll see fuel swirling. If so, replace the fuel filter.
thank you. not sure which paragraphs u are referring to. can u copy link here?
 

john zibell

Moderator
Staff member
GT di Razza Pura
Joined
Oct 28, 2008
Messages
8,513
Location
Huntsville, AL
Oh yea that video I already watched before which is why i ordered new fuel filter. do u guys think that my starting problem is connected to the fuel filter?

It acts like a fuel delivery issue. That is why I asked about your waiting for the pump to pressurize the system. The half plastic fuel filters are know to split open as they were made for use with diesel fuel, not gasoline. Usually the failure is catastrophic ( it won't run at all) which makes your situation a little more difficult to diagnose as it will run some of the time.
 

axel peemoeller

Just got it firing!
Joined
Aug 21, 2021
Messages
18
Location
New York
It acts like a fuel delivery issue. That is why I asked about your waiting for the pump to pressurize the system. The half plastic fuel filters are know to split open as they were made for use with diesel fuel, not gasoline. Usually the failure is catastrophic ( it won't run at all) which makes your situation a little more difficult to diagnose as it will run some of the time.
Cool, thank you, new filter is already in the mail. Will let u guys know once i changed it.

Thank you for now.
 

axel peemoeller

Just got it firing!
Joined
Aug 21, 2021
Messages
18
Location
New York
WTF! here a weird thing: 2 days ago i tried to start it, would not start so i left it. yesterday evening i tried again and it started right up. I did not do anything. just left it. I do not understand.

anybody got a clue?

(filter still in the mail)
 

vagrant

GT Reference
Joined
Aug 2, 2009
Messages
1,131
Location
Gainesville, Ga. or Green Valley Az.
The start button isn't a straight push in on the V7III. I don't remember if my 2015 was the same but it never gave trouble. The 2017 does from time to time ond won't engage. When this happens I need to put a lot of pressure on the button as it seems to be almost cam like in operation. It always works. Cleaning hasn't worked neither has de-oxit but try anyway.
 

axel peemoeller

Just got it firing!
Joined
Aug 21, 2021
Messages
18
Location
New York
The start button isn't a straight push in on the V7III. I don't remember if my 2015 was the same but it never gave trouble. The 2017 does from time to time ond won't engage. When this happens I need to put a lot of pressure on the button as it seems to be almost cam like in operation. It always works. Cleaning hasn't worked neither has de-oxit but try anyway.
yea but everything does turn on. and starter turns over just does not start
 

V700Steve

GT Reference
GT di Razza Pura
Joined
Dec 8, 2008
Messages
1,184
Location
Atlanta area, GA
If fuel filter is split or an internal hose issue it will fill up w/gravity while sitting and run a short time when started. It should also quit when out of gas cause it's not being fed by pump.
 
Top