Ridemalibu Motorcycle Rentals & Tours – Los Angeles CA
  1. Ciao Guest - You’ve landed at the ultimate Guzzi site. In SoCal? See the SERVICE tab above for the best in service, tires, tuning and installation of our products or custom work. NEW FORUM REGISTRATIONS REQUIRE EMAIL ACTIVATION - CHECK YOUR SPAM FOLDER. ALWAYS TRY A SEARCH BEFORE STARTING A NEW TOPIC - Most questions you may have are already answered on the Forum with FACTS, NOT OPINIONS. PLEASE DON'T BE A DRIVE-BY POSTER: As a common courtesy, check back if you are posting elsewhere on the web. Note there's decades of Guzzi hands-on experienced help on this site, all whom give endless amounts of their time for free; BE COURTEOUS AND RESPECTFUL! Also be sure to click on the STORE link also above for our 600+ product inventory, including many of our 100% Made-in-house-USA GTM products and engine kits. We appreciate the consideration, understanding and your business... past and future. And if you haven't seen our MotoCycle (not) art, click on the BUILDS tab above to see our work at our sister business; GT MotoCycles® -- WE ARE ONLINE ONLY - NO PHONE CALLS MADE OR RECEIVED.
  2. There is ZERO tolerance on personal attacks and ANY HYPERLINKS to a PRODUCT or other competing website(s), this includes personal pages, social media or other Forums. We work very hard to keep info relevant here. First offense is a note, second is a warning, third time will get you banned from the site. Sorry to have to do this, but we don't have the time to chase these. This is NOT a social media platform; It's an ad-free, privately funded website, in small help with user donations. Be sure to see our online STORE link above; GTM product purchases help support the site, or you can upgrade your Forum profile or DONATE via the link above.

2016 V 7 II won’t start.

Discussion in 'V7/V85/V9 Chat & Tech' started by Country Roads, Jun 12, 2018.

  1. vagrant

    vagrant High Miler

    Joined:
    Aug 2, 2009
    Messages:
    975
    Likes Received:
    457
    Location:
    Gainesville, Ga. or Green Valley Az.
    I have never had it on a Guzzi but did on an 86 Suzuki Samauri. A relay kit fixed it but it would at least click. There is no sound period on the V7 so i assumed that wasn't it.
     
  2. tonUPRacer

    tonUPRacer Cruisin' Guzzisti GT Contributor

    Joined:
    Sep 7, 2012
    Messages:
    220
    Likes Received:
    72
    Location:
    Appleton
    True, mine didn't click either, but after changing voltage regulators, putting in a new battery, and still having issues, I just threw more parts at the problem and in my case it worked. YMMV.
     
  3. Richard Ducati

    Richard Ducati Tuned and Synch'ed

    Joined:
    Nov 20, 2017
    Messages:
    44
    Likes Received:
    22
    Location:
    Grand Rapids, MI
    FWIW, i tried holding the starter button in after it didn't engage the starter in the normal manner...about 3 seconds elapsed and the starter engaged. I'm not going to make a habit of doing this, but it just seemed odd that it would work after a few seconds of constant starter button engagement...
     
  4. john zibell

    john zibell Moderator Staff Member GT di Razza Pura

    Joined:
    Oct 28, 2008
    Messages:
    8,179
    Likes Received:
    935
    Location:
    Huntsville, AL
    What was the last part you threw at it? That was probably the culprit.
     
  5. tonUPRacer

    tonUPRacer Cruisin' Guzzisti GT Contributor

    Joined:
    Sep 7, 2012
    Messages:
    220
    Likes Received:
    72
    Location:
    Appleton
    It was the relay bypass by MPH.
     

Share This Page